вторник, 15 октября 2013 г.

При списании инвентарного объекта при групповом учете возникает ошибка в сумме амортизации

У объектов основных средств от 3000.00 до 40000.00 возможно ведение группового учета. Проблема возникает если нам необходимо списать один из объектов. Балансовая стоимость объекта определяется корректно, а вот сумма начисленной амортизации берется в целом по группе, так же как и сумма амортизации за текущий месяц.
Ошибка присутствует в релизе 1.0.21.4 - 1.0.21.7, возможно и в более ранних версиях.

Исправить ошибку можно вставив несколько строк в общий модуль "Управление нефинансовыми активами" в процедуру "ОпределитьАмортизацию()"


РассчитаннаяАмортизация = 0;
Если НачислятьАмортизацию Тогда
// доначислим амортизацию за текущий месяц
Если СрокИспользованияДляВычисленияАмортизации > 0 Тогда
РассчитаннаяАмортизация = Окр((СтоимостьДляВычисленияАмортизации / СрокИспользованияДляВычисленияАмортизации),2,1); 
КонецЕсли;
Если РассчитаннаяАмортизация=0 Тогда
Если СрокПолезногоИспользования > 0 Тогда
РассчитаннаяАмортизация = Окр(((НачСтоимость-СуммаМодернизации) / СрокПолезногоИспользования),2,1);
КонецЕсли;
КонецЕсли;
КонецЕсли;
РассчитаннаяАмортизация = Мин(РассчитаннаяАмортизация, ОстСтоимость);
НачАмортизация = АмортизацияВсего+РассчитаннаяАмортизация;
//+ЧАН с учетом количества
НачАмортизация = ?(КоличествоВсего>1, НачАмортизация/КоличествоВсего, НачАмортизация);
РассчитаннаяАмортизация = ?(КоличествоВсего>1, РассчитаннаяАмортизация/КоличествоВсего, РассчитаннаяАмортизация);

Новый текст выделен жирным.
Следует так же отметить, что скорее всего так же и прекратится начисление амортизации на остальные объекты в группе. Данный момент следует проверить и если это необходимо установить заново параметры начисления амортизации.

Комментариев нет:

Отправить комментарий