пятница, 17 июня 2016 г.

БГУ 1.0 (1.0.40.5) Зависание при открытии карточки контрагента

Возможно зависание при открытии карточки контрагента. При этом если вводить нового контрагента, то все записывается и открывается нормально. Но если записать и закрыть и попробовать открыть карточку снова, то программа просто не отвечает.

Исправление:

Справочники.Контрагенты.ФормаЭлемента

Процедура ПриОткрытии()

РаботаСДиалогами.ЗаполнитьНовыйПоСпискуОтбора(ЭтотОбъект, СписокОтборов); // К виду контрагента отношение особое МассивОтборов = 0; РаботаСДиалогами.ПреобразоватьСписокОтборов(СписокОтборов, МассивОтборов); Если НЕ МассивОтборов = Неопределено Тогда н = 0; Пока ((н < МассивОтборов.Количество()) И (МассивОтборов[н].Имя <> "ВидКонтрагента")) Цикл н = н + 1; КонецЦикла; ЭлементыФормы.ВидКонтрагента.ТолькоПросмотр = ((н < МассивОтборов.Количество()) И   (МассивОтборов[н].ВидСравнения = ВидСравнения.Равно)); КонецЕсли; Если ЭтоНовый() Тогда Если НЕ ЗначениеЗаполнено(ВидКонтрагента) Тогда ВидКонтрагента = ПолучитьЛокальнуюПеременную("ПризнакЮрЛица"); КонецЕсли; Иначе // ЭлектронноеВзаимодействие.ОбменСКонтрагентами //+ЧАН зависает при открытии контрагента //ЭлектронныеДокументы.ПроверитьКонтрагентаВ1СЭДОПриСозданииНаСервере(Ссылка); // Конец ЭлектронноеВзаимодействие.ОбменСКонтрагентами КонецЕсли;

Изменения выделены жирным. Строка закомментирована.

Комментариев нет:

Отправить комментарий